Fehlermeldung: Datenbankmanager Btrieve kann nicht initialisiert werden

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11.01.2008 11:31
Beschreibung:

Beim Starten der von AG-V.I.P./AG-Top oder AG-Tel erfolgt sofort die Fehlermeldung:

DatenbankmanageBtrieve kann nicht initialisiert werden.

Ursache:

AG-V.I.P., AG-Top und AG-Tel verwenden bei bestimmten Operationen einen Cache für Btrieve. Die Größe dieses Cache Speichers wird im Parameter BtrieveCache des jeweiligen Programms gespeichert. Ist dieser Parameter 0, startet das entsprechende AG-Produkt nicht und es erscheint die Fehlermeldung Datenbankmanager Btrieve kann nicht initialisiert werden.

Lösung:

Auch bei schweren Initialisierungsfehlern starten die AG-Produkte im allgemeinen immer noch. Jedoch stehen Ihnen dann nicht alle Funktionen zur Verfügung. Der Zugang zu den Systemeinstellungen wird in jedem Falle ermöglicht. Nach dem Starten sollte es möglich sein, den Menüpunkt Verwaltung, Systemeinstellungen auszuwählen. Kontrollieren Sie dort, was im Eintrag BtrieveCache eingestellt wurde. Hier sollte normalerweise der Wert -1 stehen. Steht hier jedoch 0 so ist dies die Ursache der Fehlermeldung Tragen Sie hier -1 ein indem Sie auf den Eintrag doppelt klicken.

Solle das entsprechende AG-Produkt nicht mehr starten, bzw. sofort Beenden nach diesen Fehlermeldungen so können Sie den entsprechenden Eintrag auch in der Registry direkt ändern. Starten Sie dazu den REGEDIT über den Start-Knopf von Windows, wählen Sie dort den Menüpunkt Ausführen und tragen in dem anschließenden Dialog REGEDIT ein.

Wählen Sie nun je nach Programm einen der folgenden Einträge in der Registrierdatenbank durch Doppelklicken aus:

  • AG-V.I.P.: HKEY_LOCAL_MACHINE\SOFTWARE\Grutzeck Software\AG-V.I.P.
  • AG-Top: HKEY_LOCAL_MACHINE\SOFTWARE\Grutzeck Software\AG-Top
  • AG-Tel: HKEY_LOCAL_MACHINE\SOFTWARE\Grutzeck Software\AG-Tel

Auf der rechten Seite des REGEDIT sollten Sie nun den Eintrag BtrieveCache finden. Prüfen bzw. Korrigieren Sie den Eintrag wie oben beschrieben durch einen Doppelklick.

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