Fehlermeldung: Datei ist keine Datenbank oder Datenbank ist defekt

~ 0 min
11.01.2008 12:08
Beschreibung:

Der Fehler

Datei ist keine Datenbank oder Datenbank ist defekt

triit meistens auf, wenn eine Datenbank geöffnet wird bzw. direkt beim Start eines Programms oder beim Öffnen einer bestimmten Datei. Der Fehler ist gezielt wiederholbar.

Ursache:

Man kann nicht mehr sagen, als die Fehlermeldung aussagt: Entweder ist diese Datei nie von einem AG-Produkt erzeugt worden, oder die Datenbank wurde durch einen äußeren Eingriff zerstört.

Dieser Fehler ist identisch mit dem Fehler Status 2 der Btrieve Engines!

Lässt sich jedoch eine Datei im Netzwerk von einem Arbeitsplatz aus öffnen, während von einem anderen Arbeitsplatz aus dieser Fehler erscheint, so liegt hier evtl. eine falsche Installation von Btrieve vor, bzw. es erfolgt ein Zugriff von einer Btrieve 5.x Version auf eine Datei im Btrieve 6.x Format. Das gleiche Problem kann auch auftreten wenn Sie Btrieve in einer Client Server Engine mit einer Version 7.0 oder höher verwenden (Pervasive.SQL 7.0 oder Pervasive.SQL 2000).

Lösungsmöglichkeit:

Im Allgemeinen lassen sich diese Arten von Fehlern mit dem Datenbank Reparatur Programm AGDBFIX.EXE beseitigen, wenn es sich um einen Datendefekt handelt. Es ist jedoch nicht auszuschließen, dass es zu einem Datenverlust kommen kann.

Sollte dieser Fehler jedoch auf Inkompatibilität der Daten durch Verwendung einer neueren Btrieve Version verursacht sein, so müssen Sie auch eine entsprechende Version verwenden, um auf diese Dateien zuzugreifen.

Durchschnittliche Bewertung 0 (0 Abstimmungen)

Kommentieren nicht möglich