Fehlermeldung: 20 - Record Manager Inactive
Fehlermeldung: Datei ist nicht geöffnet
AG-Produkt startet nicht und bleibt auf dem Startbildschirm stehen

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11.01.2008 11:32
Beschreibung:

Bei Verwendung des Client/Server Betriebes ist es möglich, dass ein Zugriff auf einen bestimmten Btrieve Server misslang. Dann erscheint diese Meldung beim Öffnen einer Datei die Fehlermeldung 20 Record Manager Inactive.

Es wurde auch beobachtet, dass die entsprechenden AG-Produkte gestartet wurden und dass eine Datei geöffnet wurde. Allerdings erscheint bei der ersten Operation auf die Datei (z.B. Lesen eines Datensatzes) die Fehlermeldung Datei ist nicht geöffnet.

Das AG-Produkt wird gestartet. Das Programm zeigt noch das Startbild an, bleibt dann jedoch stehen und scheint abgestürzt.

Ursache:
  1. 1. In den meisten Fällen handelt es sich um einen Konflikt bei der Konfiguration von Btrieve.
    Btrieve unterstützt auch einen Zugriff auf ein Client-Server System. Ist ein solches System nicht vorhanden, bzw. kann keine Verbindung hergestellt werden, so nutzt Btrieve den "normalen" Netzwerkzugriff. In manchen Netzen kann es jedoch bei der Prüfung ob ein Client/Server System vorhanden ist, zu extrem langen Wartezeiten kommen. Die Gründe hierfür sind uns nicht bekannt. Es wurde sogar beobachtet, das zwei gleiche Rechner in einem Netz bei gleicher Konfiguration hier ein unterschiedliches Verhalten zeigen.
  2. Es kann auch sein, dass die Dateien Mkdemsg.log und Mkdewe.trn schreibgeschützt sind. Btrieve schreibt jedoch auf diese Dateien.
  3. Die Home Directory ist auf ein Verzeichnis (WIN NT; Windows) eingestellt, das schreibgeschützt ist.
Lösung Problem 1:

Durch das Ändern einer Einstellung innerhalb von Btrieve kann der Client/Server Betrieb abgeschaltet werden. Dies sollte natürlich nur geschehen, wenn Sie wirklich keinen Client/Server Betrieb für Btrieve in Ihrem Netz haben. Im Allgemeinen ist dies nicht der Fall und Sie können den entsprechenden Parameter problemlos ändern. Sollten Probleme mit anderen Software Modulen auftreten, so können Sie jederzeit den entsprechenden Parameter wieder zurück auf den alten Wert stellen.

Zum Ändern der Einstellung gehen Sie in folgender Weise vor:

  1. Starten Sie dazu den REGEDIT über den Start-Knopf von Windows, wählen Sie dort den Menüpunkt Ausführen und tragen in dem anschließenden Dialog REGEDIT ein.
  2. Wählen Sie nun je nach Programm einen der folgenden Einträge in der Registrierdatenbank durch Doppelklicken aus:
    HKEY_LOCAL_MACHINE\SOFTWARE\Btrieve Technologies\Microkernel Workstation Engine\Version 6.15\Microkernel Interface\Settings
  3. auf der rechten Seite finden Sie nun 3 Einträge:
    LoadRetries 0x00000005 (5)
    Local 0x00000001 (1)
    Requester 0x00000001 (1)
    Entscheidend für dieses Problem ist nur der Parameter Requester. Doppelklicken Sie diesen Wert und stellen Sie ihn auf 0.
  4. Starten Sie den Rechner erneut und versuchen Sie das AG-Produkt zu starten. Es sollten keine weiteren Probleme auftreten.

Nachfolgend sollen hier noch einige Produkte aufgezählt werden, die nur dann verwendet werden, wenn Sie den Requester Eintrag auf 1 setzen.

  • Btrieve für Windows NT Server
  • Btrieve für Netware
  • Pervasive.SQL 7.0 (für Windows NT oder Netware)
  • Pervasive.SQL 2000 (für Windows NT oder Netware)

Ist eines der hier aufgezählten Produkte auf dem Server installiert, so lassen Sie bitte von Ihrem Netzwerk Administrator kontrollieren, ob die aktuellen Netzwerk Client Software für das entsprechend oben aufgezählte Produkt installiert sind.

Lösung Problem 2:

Entfernen Sie den Schreibschutz auf diese beiden Dateien.

Lösung Problem 3:
  1. Starten Sie Regedit.
  2. Wählen Sie den Pfad
    HKEY-LOCAL-MACHINE\Software\Btrieve Technologies\Mikrokernel Workstation Engine\Version 6.15\Settings
    dort den Eintrag für Home Directory
  3. Tragen Sie dort ein temporäres Verzeichnis ein, auf das ALLE Benutzer Lese- und Schreibrecht haben.

 

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