Fehlermeldung: Interner Fehler 2753. CodeMeter.exe,A961A077_4BD0_4C98_86BC_EE4A98CE550D bei Reparaturinstallation oder Deinstallation von AG-VIP SQL 1.20.005

Martin Richter [Grutzeck Software GmbH]
02.09.2009 14:13
Problem:

Wird eine Deinstallation oder eine Reparaturinstallation der AG-VIP SQL Version 1.20.005 durchgeführt kann es zu folgender Fehlermeldung kommen:

Interner Fehler 2753. CodeMeter.exe,A961A077_4BD0_4C98_86BC_EE4A98CE550D

Das Setup wird in diesem Fall sofort abgebrochen. Die Softwarekann nicht deinstalliert werden und es kann keine Reparaturinstallation durchgeführt werden.

Betroffen sind nur alle Updates oder Installationen von AG-VIP SQL 1.20.005, die vor dem 02.09.2009 von unserem Server heruntergeladen wurden. Bzw. CDs die vor dem 02.09.2009 erzeugt und versendet wurden. Andere AG-VIP SQL Versionen zeigen dieses Fehlverhalten nicht.

Ursache:

Die Ursache liegt in einer Komponente, die nicht installiert wurde, bzw. fälschlicherweise als installiert erkannt wird.

Workaround:

Laden Sie sich bitte die Datei HotfixSetup1.20.005.vbs herunter. Sie finden den Link zu diesem Download unter diesem Artikel.

Achtung: Der Hotfix kann nur ausgeführt werden, wenn Sie als Administrator angemeldet sind.

Sofern Sie die Fehlermeldung auf einem Windows XP, Windows 2000, oder Windows 2003 Rechner erhalten genügt es diese Datei einfach durch einen Doppelklick im Explorer auszuführen. Es ist auch möglich dieses Script in einem DOS-Fenster durch den Befehl
cscript HotfixSetup1.20.005.vbs
auszuführen.

Sollte die Installation auf einem Windows Vista oder Windows 2008 Server erfolgt sein, so gehen Sie wie folgt vor:

  1. Klicken Sie auf den Start Schalter.
  2. Geben Sie cmd.exe ein.
  3. Klicken Sie mit der rechten Maus Taste auf den Eintrag cmd.exe und wählen Sie Als Administrator ausführen.
  4. Geben Sie nun den Befehl
    cscript <Pfad-der-VBS-Datei>\HotfixSetup1.20.005.vbs
    ein.

Bei korrekter Ausführung erhalten Sie die Meldung:

The patch for the MSI file of AG-VIP SQL 1.20.005 was successfully applied!

Wurde der Patch bereits installiert, oder ist Ihr Setup von AG-VIP SQL nicht von diesem Problem betroffen (Update nach dem 02.09.2009), dann erhalten Sie die Meldung:

This MSI file of AG-VIP SQL 1.20.005 is already patched!

Ist auf diesem Rechner AG-VIP SQL in der Version 1.20.005 nicht vorhanden, oder eine neuere oder ältere Version installiert, dann erhalten Sie die Meldung:

AG-VIP SQL 1.20.005 is not installed! 

Andere Fehlermeldungen deuten darauf hin, dass Sie nicht als Administrator angemeldet sind, oder keine Rechte haben das entsprechende Setup Modul zu verändern.
Wenden Sie sich bitte an unseren Support.

angehängte Dateien: HotfixSetup1.20.005.vbs

Tags: 2753, CodeMeter, Installation
Durchschnittliche Bewertung: 0 (0 Abstimmungen)

Kommentieren nicht möglich